Symptoms
There is no value in the Site Owners field for a given site.
Cause
Even if you can see the default "MySite Owners" group on your site, it is possible that it is not set as the "Owners" group of your site. If you don't see the group members in the Site Owners field of ShareGate Desktop, it most likely means that the group is not set properly.
Resolution
To set the "Owners" group of your site, along with the "Members" group and the "Visitors" group, you have to go to the following URL on your site: <MySiteUrl>/_layouts/permsetup.aspx
Unfortunately, this page must be accessed with the previous URL as there is no way to navigate to it through the SharePoint navigation.
On this page, if the "Create a new group" radio button is selected, it means that no groups are set. Simply choose "Use an existing group" and select the appropriate group for each category. Click Ok and now if you refresh your site in ShareGate Desktop, you should see the appropriate users in the Site Owners field!